REST API response array as data source for Select component

I have a Select component where I want the data source to be the response from a REST API, that returns an array. However, I can't get it to work. The Select component shows an error as displayed below. The image below also shows the response from the api, as well as the configuration of the Select component. What am I missing?

This is what the {{ item }} in the Select configuration shows:

And if I click to "set the values dynamically" I can still see that the data is there, but it's not being recognized somehow:

If I just copy paste the response into the data source, it works. So I'm not sure if this is a bug?

Hey @juri, those screenshots are perfect, thank you so much for sending them over! That’s odd :thinking: I’ll test on my end to see if I’m able to populate a dropdown with values

Since hardcoding works, I wonder if the component is trying to populate before the query finishes returning data. If you create a new dropdown (after the app is finished loading) and then add the lsitHelpPageTitlesJson as the data source, does it work?

Ah yes, thanks @victoria! I set the query to run on page load, and now it works.

I tried {{ listHelpPageTitlesJson?.data ?? [] }} the other day, because I wondered if it might be something like what you suggested, but that didn't work either. I'm starting to learn how retool works now though. Thanks again!

Ah fantastic :man_dancing:t2:

Hmm I think {{ || [] }}might work! That would return an empty array if there’s no query data.