REST API - Baserow DDB Connection -

Hello everyone,

I wanted to connect my Baserow database with Retool. Followed all the steps along and looked that the authetufucation is correctly, but it didn't work out, no matter what I tried.

I looked up the resources and made sure I filled out the necessary fields correct for connecting.

Unfortunatley I get the error "Permission denied" as you can see in my screenshot.

For the screenshot I changes the token to 'xxx' but normally I typed the right one in.

Thank you in advance!


Hi @Viktoria_Naumann,

From the looks of the Auth docs on Baserow, you should change the word Token in your header to JWT.

If you're using a public database token, then the docs here should be customized to your database - they are blank for me as I don't use Baserow, but if you login, you should see the details. It's possible those docs tell you to use the word Token instead of JWT - can you share a screenshot of them (with any tokens / info hidden). But first, try changing it to JWT and see what happens.

Hello Mike,

thank you for your help.

unfortunately the I followed the API documentation you provided me and I filled out everything correct..

You're right, it looks like when using a db token, you should use Token rather than JWT.

A couple things I noticed - In your second post, you have the Authentication section of the resource filled in. From reading a bit about Baserow, you can either connect with a JWT for a "full" connection, or with a "database token" which gives you basic CRUD access. Getting the JWT token requires a call to an endpoint with your username and password, which responds with a JWT token that's valid for 60 minutes. That token goes in your Authorization header as JWT xxxxxx, the database token goes into the Authorization header as Token xxxx, but the values are different and you don't use both on the same call.

Can you confirm that you've generated a database token and don't have any other authentication configs set up on your Baserow resource in Retool?

Also, in your last screenshot it showed you accessing a different table ID than the earlier screenshots and your docs, so double check that it is accurate, because the token is specific to your account.

yes @MikeCB I can confirm that I have only one workspace for which I generated a Database Token and implemented it.

With the Authorization through Token and the token afterwards it's swell getting denied.

And yes the table ID- I tried multiple endpoints so that's why it's still standing there, but there is an endpoint provided which is generated for the table.

Unfortunately my problem is still not solved.. can someone help me? @MikeCB


Have you been able to connect to the API with that token via anything else? IE Postman or CURL to confirm that the token is valid/working? Also, can you confirm if you removed the authentication
this part:

from your Baserow resource config? Maybe a screenshot for the API Request tab of your PERMISSION_DENIED query could help to see the full request body/headers?