Renaming Table with Context Menu Issue

While in the database area of ReTool, when you click on the tab of a table and try to select rename the menu flickers a little and nothing happens.

If you double click the tab, it switches to an edit box, but the context menu entry does not work.

rename

I can't duplicate this, i might be doing the order of clicks wrong or something.

  1. click to select tab
  2. double click name
  3. click blank space to end edit
  4. click context menu
  5. click rename

:man_shrugging: ya i don't know, just tried again a few times and mine goes back into editing the name. does a page refresh or closing/reopening the browser fix it?

Here's what I did:

  1. New tab
  2. login to retool
  3. go to database section
  4. open a table from my list
  5. click the chevron on the tab
  6. click rename
    -> this is when it flickers and I don't get the edit box

I can't duplicate this either. I tried closing all my tabs and leave only one table, but still not able to reproduce this.

image

1 Like

I can confirm it is a Firefox bug as it does not happen in Chrome. I will continue to investigate.