Query works in Postman but not anymore in Retool


I had a query that makes a PUT request to change stock level in my resource. I set this up a few weeks ago and all was working as expected.

However when I now run the same PUT request I get a 404 Request does not match any route error.

I tried another PUT request to the same resource which I had also set up which was working as expected. While this one returns a 200 code the actual attribute it had previously been updating now no longer changes.

-When I run the same requests in Postman they work as expected.
-My GET requests still work as expected.
-I had not changed anything to do with the query or the underlying resource.

I have tried:

  • Reauthorising my resource to confirm not an authorisation issue
    -Hardcoding the values into the request to confirm the same values are being sent as in Postman.

Any ideas as to how I can fix this? Considering my GET requests still work as expected I am thinking it might be something related to how the body is being sent?


Coming back to this a few hours later and seems to be back to working as expected now. :thinking: