Query preview working but not running

Hi, I am facing some errors when trying to obtain data from an API Rest resource.
When clicking on preview, the query runs smoothly. On the other side, if I run the query it gets stuck.
I cannot see any errors in the Audit Log (the response is a 200) but the data object keeps empty.
Any workaround here? thanks

Hi @annafonte! Would you mind sharing a screenshot of the query you're running? Did this query ever work?

Hello, I have problems with this API, it seems that also happened as indicated here, serves when I give the Preview button, but does not serve when I give to Run, or if I trigger the event from a button, how can I check this further, will be problems of the API DataForSEO, or how to configure this API Rest to wait longer response, since I consult the side of the API, and I notice that if you have sent a response to Retool.

Thank you very much for your comments for your help.

I solved it, I managed to increase the response time and this helped me, thank you very much.