Query library variables bug

steps to reproduce:

  1. add a new query
  2. add a header parameter that is the same as another query (but leave value blank)
  3. save it
  4. go to another query that has the same variable
  5. click back to the newly saved query
  6. the variable now shows a value in it
  7. test the query by running it
  8. the value is not "seen" by the query even though it looks like its filled
  9. clicking back and forth between queries still shows the values saved
  10. go around in circles and insane cos the gui is broken

please fix this

heres a pic

Hey there, I tried to reproduce this behavior but when I run the new query the variable's value is filled in ("value" in this screenshot from the Retool debugger):

Could you share a screen recording reproducing the issue?

Also, are you using Retool Cloud or self-hosted? If self-hosted, which version?

self host 3.37.0

they dont let me install software on this work pc, maybe i can record using my phone, ill get back to you...