Query JSON with SQL Select doesn't allow for conditional statement with arrays

I have tried every suggestion I've found on the community as well as the greater google-verse, but I still can't figure out how to create a WHERE statement with an array of values from a selection.

Here's the query with it typed out (which works!):

And here is the selector:

And confirmation that the selector is spitting out TX and AL:

This DOES NOT work:

This DOES NOT work (but DOES work when you have a "regular" query from Snowflake):

I have even tried this, which someone suggested on some post, but DOES NOT work for me:

I'm at my wit's end. How on earth can I do this?!


Hey @mathfour
You can see previous answer here and again in docs.

This looks to be working. Give it a try?

I'll try that!

I totally didn't see the @ sign! Thanks for including a big screenshot of it.

This will help so many of my queries that are hitting snowflake that I've been thinking, "If only I could use that other query and do this one as a Query JSON with SQL!"

I'll let you know how it goes when I can get in (I have to wait for other team members to get out because, y'know... we can't develop at the same time. But I'm sure you get that request all the time. ;))

1 Like

I've seen a good amount of multi-player requests on this forum, and I've heard from the team that they're all super hyped for it too. All in due time!

1 Like