Query cache not working correctly

Hi everyone

I tried to use the cache functionality to cache the results of a query because this query is being called quite often. Query type: "DB Query Postgres"
The cache duration was set to 600 seconds. However, after making a change in the DB, I tried the cache and it returned two different result sets randomly when clicking on "Run".

  1. result set: query output before my DB change
  2. result set: query output after my DB change

The query was not changed. I tried it multiple times and it's always reproducible with my setup.
The whole cache logic is unusable like this if the results are basically random. I made a video of the always changing results for better illustration (see link below).

Retool version:
2.95.6 (self hosted - on-premise)

Link to the video:

Hmm very interesting.

Can you run the query and use these parameters to test and see if they are ever evaluated incorrectly?


Also, I think using a Redis DB for on-prem deployments is the best way to use cached results.