Queries time out from Retool but work great from my laptop


I have a Postgres connector that's very flaky on Retool Cloud.
This connector has been in usage for 6 months and worked great.
Suddenly in the past few hours it is very flaky and times out on most requests. The same request can time out 5 times and then work, then time out again. The time out is very long config - 120s.

When performing the same requests with the same user credentials from my laptop, I consistently get results in under a second, so it seems to me there's some issue between the Retool frontend and the Retool backend.

The DB is hosted on AWS us-east-1. This isn't a network security issue because sometimes the queries work.

Please assist ASAP, this is breaking our production environment. Thanks.

EDIT - to confirm, I tried running "SELECT 1=1" which should immediately return a result - it still times out.

Hi, sadly I got no reply and this is happening again.

This is still relevant 2 days later and I still got no reply

Hey @ypeled sorry for the delay on this, I'll escalate this internally to our team. In the meanwhile have you contacted our support team about this directly? They can be reached at support@retool.com

Thanks for your patience!