Putting a Field Value on Scree,

I would like to put a field value as a single square on screen.

The field value is in Storage2.TOTTAX. When I enter Storage2.TOTTAX as the default value, the screen just shows these words not the value of the field.

I have tried a default value of value(Storage2.TOTTAX) and again it just puts those words up, not the value.

What is the syntax for doing this?


Hey @mdsmith1!

I wonder if you might be looking for {{ Storage2.TOTTAX }}. If that doesn't work screenshots might help!


I tried {{ Storage02.TOTTAX }} and that didn't work. And nothing showed up on the screen.
I tried {{ 'Storage02.TOTTAX' }} and that shows the same string not the value of the string.
I am attaching a screen capture of the second attempt because it gives a better picture of the problem.

:thinking: what is Storage02 in your app? Would you mind sharing a screenshot of that?

Hi Henry:
Storage02 is a 1 row table that holds all my memory variables.
I use a tool called cPanel for managing my tables. Here is a screen shot.

I see, do you have a query set up to fetch from it in Retool?

Henry: I have played around with this and I am pretty sure that I need memory variables in these squares.
The only storage that ReTool has for memory variables is Local Storage so that is what I am going to use.
I was trying to get away from Local Storage because I find it unstable but I think I will have to live with this.
So I am closing this case and I will mark your last comment as the solution.


I think I have figured out the problem with local storage.

I have discovered (maybe only on my computer) that if I can’t do Restore and Local Storage one after the other because it picks up the old values because the Invoice Table is not fully established on my computer. So I gave it another Task (Save Company) to do first. And now it works perfectly.

I have attached a screen shot. You will see the 3rd last row is “Save Company”. Its busy work which gives the Tax Total and Grand Total time to get settled on my computer so their new values can be sent to Local Storage.

This may only be happening on my computer but I thought I should pass this on just in case there are others.