Problem when updating existing record with form


Super newbie here. I'm trying to build my first app.

I simply want to update a row of my Retool Database via submission of a form. The form has its "Data source" field set with the existing record. The submit query should update such record and it's set like the image below (Changeset Object).


The problem is that this work only if I change every single field of the form. If one or more of the fields are not changed, the text fields in the record are updated with extra curly brackets.

For example if an unchanged field starts like this: Napoli
At first submission becomes: {"{"Napoli"}"}
At second submission becomes: {"{"{\"Napoli\"}"}"}
And so on..

Numerical fields, if unchanged, raise error like this:

  • invalid input syntax for type integer: "{"400001"}"

I also tried Changeset Key value pairs with the same results. I tried also starting all over from scratch with a blank app but the problem is still there.

Can you please help me with this?
I'm surely missing something very basic :slight_smile:

Thank you