Possible bug in new table currency code field


I am in the process of switching our pricing system to use the new Retool table component after using the Legacy table previously. In the Legacy table we can reference the current row to retreive values from other columns but it seems we cannot do this in the Currency Code field of the Currency column type on the new table for some reason? We store the 3 digit currency code value in a seperate database column and then previosuly referenced this column as the source for the value which worked as expected. But the new table component doesn't appear to allow us to do this. Is this a bug or expected behaviour? See screenshots below, thanks.

Legacy Table


New Table

Hi there,

Facing the same issue. Have tried with currentRow and Item and in both I get the error "XX is not defined"

Hello, it seems to work for me

Thats good to know. It used to work for us too. Can i ask what version of Retool are you using? We are using self-hosted v3.26.4


Hey, I'm in cloud version 3.30.0

using currentSourceRow works even if linter says it is not defined and shows error messages
seems odd, but at least it works