Open app action (utils.openApp) stopped working today

Hey folks -- I have ~15 critical apps that are interlinked and have a simple little "nav menu" module that connects them together. It has worked for months without problem, all using the button component tied in to the "open app" command. It worked great, until today.

Now it just doesn't work. The button click does nothing. No errors in the JS logs that I can see. If I add a confetti action to debug the button click, it works. If I change it from "open app" to "open link" it works.

This screenshot shows the action handle that no longer works and also in the background you can see I wired up an action handler (utils.openUrl) that does.

Please fix :pray:


Same issue here - can elaborate further on what I'm seeing too.

utils.openApp throws an error in the console:

Error:Cannot read properties of undefined (reading 'path')

But this only happens in Preview mode. If I'm in Edit mode then it tries to open the App although it does come up with a strange url when it does, eg:

Where the name of the app gets replace with "undefined" although the appuuid appears correct

Taking a look at this urgently now!

1 Like

Hi ! Same here, utils.openApp throw this error : "
Error:Cannot read properties of undefined (reading 'path')

On top of that, it is really weird but the utils.openApp works when I navigate in between apps in Admin mode. However, it doesn't work when trying to click in preview mode.

Thank you for adding. your +1 and additional context here! Our on call engineers are looking into this and I'll make sure to update this post accordingly :slightly_smiling_face: For anyone else seeing this and running into the same issue, please feel free to add your +1 as well!

Quick question. After testing more on our side, it looks like utils.openApp will work if you just wait long enough for the /pages API hit to finish (basically, for the page to finish loading). Does this sound correct to y’all?

No on preview mode, on my side waiting doesn't work / help
On Edit mode, still having the undefined url appearing : //

Not here, sorry, never works in Preview mode no matter how long I wait, and acts strange in Editor mode with that "undefined" url that gets added instead of it finding the app name.

Got it, thank you!

I'm having the same issue. It may or may not be related, but the tab title and url path is undefined.

We actually just deployed a potential fix! Are things working as expected now? :crossed_fingers:

For me it does work now !
Thanks a lot @Victoria & the retool team, really helpful for our operations.


1 Like

Working for me again, thanks!