Open API v3

Is there a time line when Open Api version 3 will be supported by retool?

Hi Mark! We’re investigating supporting OpenAPI 3.0, but as of now we don’t have a concrete timeline.
Can you let us know what OpenAPI spec you’re trying to use so we can make sure we support your spec when we’re able to support 3.0?

Good day Ryan,
The API is being developed in-house and the tools / libraries only support publishing an Open API 3.0 specification. Our API does make use of Firebase Storage, so if Firebase Storage is supported by Retool then I can work on those areas of the front-end until the Open API 3.0 is supported.
Thank you.

Sounds good, Mark—thanks for the feedback! If you run into any issues with the front-end work on top of Firebase, let me know.

Hey Mark!

I just wanted to follow up here to share some good news — we’ve pushed support for OpenAPI v3! :blush:

When you say pushed do you mean it is on SaaS and On Prem. We are trialing both right now trying to import a v3.0.1 spec in JSON or YAML just results in a spinning loading wheel. Test connection works and we see the GET request on our API.

Worked through this with holoplot in chat support!

The spec has to be served over HTTPS to avoid browser mismatch errors! The Swagger Inspector can be used as an external source to check if your spec is accessible!

hello, @Chris-Thompson

I can connect to holistic using postmen.
But I can't connect retool to holistic, I'm not sure if it is because retool does not support openai 3.0.2 ?

Hi @jay88 !

Are you seeing any errors when attempting to connect? Are you able to successfully load the Holistic API schema in your query editor?

I get an error when I use the openapi method.

Finally, I used the restapi method to connect successfully.

Maybe I don't know enough about openapi and restapi, and need more time to learn.

Hi @ben

thank you for your help.

I imported the openapi Specification file of holistics into postman and it can be accessed successfully.
My holistics is a standard account, there is no ip restriction function.
I think it should not be the firewall or ip restriction of holistics.

I uploaded the openapi Specification of holistics to the server
The following error occurred.

I see! That's very helpful - I just tried to fetch the spec from your server and it seems that I'm getting a CORS error:

You may need to configure your server's networking to allow access for the Retool domain