Oauth 2.0 - How to prompt user for login?


Try to build a classic OAuth2 flow with Retool.
When retool run the authentification url it adds "prompt=consent" in url.
How to override this behaviour ? The API I'm using need that I use "promp=login" or nothing

Thank you


Thank you, I've seen this doc.
So I cannot use Oauth2 component for my Oauth2 auth?

I don't think that it applies to my question

Ok I've founded how to keep my url parameter "prompt=non" so the oauth works.

But when going on the live interface, user don't have oauth2 redirection if no token.
I don't have checked the "Client credential flow"

oK it's beause I'm in public mode.

End of my problem


I've run into the same problem. How DID you keep your URL parameter to "prompt=non"??

[Your thread is the only one that comes up for a "prompt=consent" search!]


Simply add the parameter in the Oauth ressource

Thanks Quentin! I'll try it.