Not working in Preview Mode

I have a screen working with a number of features.
I have now introduced a search box with some code from one of the examples.
The search feature works fine in development mode but when I run it in Preview Mode nothing happens when I click on the Search Button.
I am attach

ing a screen capture

Hey @mdsmith1!

Would you mind sharing screenshots of how you have your search bar configured as well as the queries that are attached to it?

I am attaching 2 screen shots. The first shows the code for "getdata" along with the search input field.

The second shows the code under the Search button.

Hey @mdsmith1!

I'm not seeing anything particular in the query. How are you passing data to the table itself?

If you're ok with it, we can take a quick step into your org to look at this app which might be helpful as well!

I have Team Viewer on my computer of you would like to take a look.

Hey @mdsmith1!

Just want to follow up here for anyone who stumbles across this thread - we tried making sure {{ }} to the table and switching the query code to

select * from Test01 where {{!searchinput.value}} or last like {{searchinput.value +'%'}} order by serialno

in accordance with these docs.

It seems like that fixed the issue but let me know if I'm missing anything :slightly_smiling_face:

Yes, Kabirdas, you have summarized things accurately. Thanks for your solution for this.