Not able to hide space of a field when hidden = true

I have a few fields that are conditionally hidden like so -


When they are hidden, I don't want them maintaining their space aka the field should behave as if it is not there. I have kept this box unchecked for this very purpose -


Here is the editor view of the fields -

And here is the preview, which shows the unwanted spacing -

fwiw this was working fine before I copied all these components and pasted them inside a tabbed container. This is what it should look like, what it looked like before:

editor view:


the settings for each text fields is exactly the same before and after, however they are behaving entirely differently

Any help is appreciated, thanks!!

Right click on the component and Refresh state then preview again and see if that works

good idea, no luck though @ScottR

I am on cloud version and I don’t see that issue. Are the fields in a container or something else like a ListView and the heights are fixed? Also try creating another field and place it in between other fields and hide it and see what happens

Weird, so creating new fields from scratch, as opposed to copy pasting them, solved it! :person_shrugging:

Thanks @ScottR!

1 Like