MongoDB ressource regression: Error: option sslinvalidhostnameallowed is not supported

Hello everyone,

Since Monday October 25th 2022 we can't access our MongoDB ressources anymore.

The error message is: "Error: option sslinvalidhostnameallowed is not supported"

It was working perfectly before for several months. The problem is not with the MongoDB server as I can connect with the same connection string using a desktop client. The problem is also not related to firewall / IP whitelisting issues as it seems I'm blocked by Retool before even being able to access my MongoDB instance.

It seems that Retool does a kind of filter of arguments of connection strings and that they now refuse sslinvalidhostnameallowed=true argument eventhough without further notice.

Here's my connection string:


Does anyone has the same issue? I know that skipping SSL/TLS validation is not a best practice and risky but for short term I need to do this before using a better solution.

Thanks in advance for your help.

Best regards,

I'm facing a similar issue to connect the resources which are working fine locally. In my case, I tried both the connection string and the detailed connection string. I'm facing this issue since 22nd Oct 2022.

Unable to connect. Error: Could not establish a connection. Try checking your database firewall configuration and whitelisting Retool's IP Address

The IP address is whitelisted already and it was working fine before.

1 Like

This was resolved over chat! Caused by a bug on our end that we've since rolled back.

Thank you for reporting this, @naveenrajv! :pray:

1 Like

Thank it was working fine but, I'm facing the same issue again now.

1 Like

@naveenrajv @victoria Yes, same on our side, issue is back again now.

1 Like

Please check, still facing the issue @victoria

Looking into this!

Looks like we have a fix for this behind a flag! For anyone who's affected, please email me at:

(weird address, I know :sweat_smile: but that's to ensure that your message comes straight to me inside of our chat/email platform)

with the name of your subdomain and I'll make sure to enable the flag for you!

The connection is working fine now @victoria, Thank you :smile:


1 Like

Of course! I’m sorry it broke in the first place, and thank you for letting me know it’s working now

1 Like