Module dropdown options not showing in app

I have a really simple module to work out some common date ranges.

The idea is you choose one of the date range options (previous three months, year to date, etc) and it calculates and sets the start and end date selects.

These values are added as output values to the module to use in queries.

Here's the module:

I've tried the date range options as both hardcoded and also from a JS query, which work fine in the module, but don't show up when I use the module in an app.

Here's the app, you can see here the options aren't showing:

Any ideas why the options would be blank when shared?

EDIT: A bit more detail. Here's the query to build the options:

Again, I've also tried setting these as hard coded values in the component.

Ok, I think this was happening because the default value I set against the component doesn't match the available options.

Once I fixed that, I reverted to a hardcoded list and it's working as expected in the app.

1 Like