Missing Server URL selection


We have set up a new OpenAPI Resource the same way as we set up our existing one, but with a different openapi spec.

On the existing one we have a dropdown called "Server URL" based on the available servers in the openapi spec.

On our new resource it is missing that dropdown. So we can not select the default servers for staging/production. If it matters we do have 4 instead of 2 servers in the spec.

We can not find any setting anywhere to get the Server URL selection displayed.

How can we select a default server per environment?

Hey @Bernd_Strehl! We conditionally show that dropdown based on the number of servers that we find based on our parsing of the spec. Sounds like we aren't finding the proper number on servers on the new spec you are using. Can you share the spec url so we can test / figure out going on (can send via dm)? If you aren't comfortable sharing it, any additional information about the spec would be great so I can try and repro and get a report over to the team. Thanks!

hi @joeBumbaca , I shared it privately in a call with one of your PMs.
So it is expected to only have 2 servers?

Having two instead of four servers in the openapi spec is not solving the problem.

@Bernd_Strehl I don't believe the number of servers is causing the problem. For some reason, we aren't finding more than one when we parse the spec. If you can share the spec with me, I can reproduce / investigate the issue so that we can figure out why.

We've solved this question with the customer over slack/email. For posterity, it's due to CORS issue with their OpenAPI spec server that prevents Retool client from fetching the spec. Because Retool client failed to fetch the spec, it also failed to detect the available servers. Fixing the CORS setting (to Access-Control-Allow-Origin: * solved the problem.

1 Like