Migration Error: 'googleToken' column does not exist

Hello, I'm configuring a self hosted deployment in Kubernetes using the helm chart and an external managed postgres DB running in Azure.

The issue I'm experiencing is that the retool pod gets into CrashLoopBackOff state. The logs show the following:

Acquiring lock to run migrations...
Acquired lock
Running database migrations...
  event: 'migrating',
  name: '20170627021252-change-user-google-token-to-text-type.js'

-     EXITING RETOOL      -

Error running database migrations: MigrationError: Migration 20170627021252-change-user-google-token-to-text-type.js (up) failed: Original error: column "googleToken" of relation "users" does not exist

I've tried with the latest version available at the moment: Self-hosted Retool 3.22.1

Any ideas of why is this happening? The db at which I'm pointing is empty and I'm assuming the migrations should create all the schemas necessary for retool to run.


This was an error on my end. I made a mistake setting the DB_NAME env variable and I was pointing to an existing non empty db. This db had a users table already, thus the error: column googleToken of relation users does not exist

Hi, glad you got this worked out! Really appreciate you posting the update and the solution.