Loop - SQL Server


My workflow uses a Loop block that inserts data into our SQL Server. I use this all over the place in our workflows. For some reason this one fails every time if I run the workflow as a whole. If I run the blocks individually it succeeds. Error message below.

Error: Undefined binding(s) detected when compiling SELECT. Undefined column(s): [AppleIdentifier] query: select count(*) as [count] from [dbo].[APP_STORE_download_data] where [AppleIdentifier] = ? (line 6)

Please help. This is a bug. I'm not even passing this value into the update!

Please I need help with this. Our workflow keeps failing and its important for ingesting data.

Hi @nhilbelink! Happy to help here. Would you mind sharing a screenshot of the query itself?

Here are the preceding steps and the query itself. The block labelled parseTabData does contain the field called Provider and it returns that just that field with an empty value at the end of the document. This is why ParseTabData has 3 items in the data array but with index 2 only having that single key. To not have issues with that field during the upsert, I then Filter out the row that only has a single key leaving me with the two good rows. For the Upsert action itself, I've tried using Key Value Pairs and the Object and both result in the error above, though they do partially complete the upsert. Its almost like for some reason the SQL Upsert is looking at the parseTabData results rather than the Filtered results.

This still isn't working and now I am creating another new workflow that needs to insert data into our SQL Server and I can't make this one work either. Exact same issue. I am sending data to our Microsoft SQL Server.