List View inside a table expandable row does not display the correct data

Hi :wave:

I am running into some issues while building something that should be relatively straightforward :

I have a query who returns a list of data, with one of the columns being a list (so, a list of lists). I want to display the information contained in the nested list in a ListView contained inside the expanded row in a table.

So I set up the list to display currentRow.listOfStuff
However, when inside of a repeatable I reference i or item, they incorrectly refer to the listOfStuff of the first row in the table rather than the row I am interested in.

Is this expected behaviour ? If yes, how should I go about building what I want, which is displying content in a nested list inside the expanded row of a table ?

Hi @pjmv,

I'm happy help you out with this! Would you mind sharing a screenshot of your table and the table's data source?

Hi ! Thanks for the help
Here is what I think is relevant :

As you can see the row contents are the same in the first and thirds rows which is not the intended behavior

Thanks, the additional context really helps!
Updating the Primary Key for the distributionContentList to {{ item }} and using item instead of currentRow inside of the value for containerTitle1, may resolve this issue for you.

If it's still not working, I'd be happy to take a look at an export and data. :+1:

Hi Abbey,

Thanks for the initial help but it does not solve the problem. The data referenced in the row content is the same across all rows despite my data not being the same


Finally solved it by redoing everything, making sure to use the new List View component, referencing CurrentSourceRow without overriding the primary key in the List View data input and otherwise following your advice (ie, using item in the containers). It seems to have done the trick.

:raised_hands: I'm happy to hear! Thanks for sharing your solution.