Hi all,

I recently installed Retool into one of our production clusters but I'm seeing the following messages in the log and am unable to login.

retool-7d48cd57cd-4lz64 retool {"level":"info","message":"Rechecking license status...","timestamp":"2023-12-06T00:04:48.353Z"}
retool-7d48cd57cd-4lz64 retool {"level":"info","message":"license check http response code: 200","timestamp":"2023-12-06T00:04:48.829Z"}
retool-7d48cd57cd-4lz64 retool {"level":"info","message":"License key feature flag overrides: {}","timestamp":"2023-12-06T00:04:48.833Z"}
retool-7d48cd57cd-4lz64 retool {"level":"info","message":"Updated license status from licensing server","timestamp":"2023-12-06T00:04:48.833Z"}
retool-7d48cd57cd-4lz64 retool {"level":"error","message":{"stack":"Error\n at (/node_modules/sequelize/lib/dialects/postgres/query.js:50:25)\n at /node_modules/sequelize/lib/sequelize.js:315:28\n at process.processTicksAndRejections (node:internal/process/task_queues:95:5)\n at async PostgresQueryInterface.upsert (/node_modules/sequelize/lib/dialects/abstract/query-interface.js:341:12)\n at async temporalCloudSetting.upsert (/node_modules/sequelize/lib/model.js:1533:20)\n at async Sc1 (/retool_backend/bundle/main.js:3625:4065)\n at async $M (/retool_backend/bundle/main.js:3625:2446)\n at async Timeout._onTimeout (/retool_backend/bundle/main.js:3625:5941)","type":"LICENSE_FETCH_ERROR"},"timestamp":"2023-12-06T00:04:48.838Z"}
retool-7d48cd57cd-4lz64 retool {"level":"info","message":"Updated license status from DB","timestamp":"2023-12-06T00:04:48.841Z"}

Initially I had deployed Retool into a test cluster and it worked fine. No license errors in the logs. I'm using the same license code in the configuration for both Retool servers as the test deployment was just a way for us to assess Retool before migrating it to the prod cluster. Stopping the test Retool server does not appear to impact this error.

Any ideas what might be the issue?

Many thanks.


Hi Des,

It looks like we're hitting a timeout error when trying to connect to our license servers. My first guess would be that the new production server might be behind a firewall of some sort which isn't letting your local retool instance connect to our license servers? Are your production servers more locked down than the test cluster you set up, or is there the potential that the test cluster had its firewall set up differently?

Hi Adrian,

Thanks for the reply. I did try accessing the Retool endpoints, as documented, from the production Retool instance and I was able to. So it would appear not to be NW related. Also, after trying a number of things the license error went away. I think the issue was DB related but not entirely sure. Thanks for your help.


1 Like

Glad it got worked out. Sorry about the intermittent error here. I'm going to close this topic off since it's been worked out, always feel free to start up new threads if you need any more help from us or the community!