Inputs in form act funny

Hi retool community!

I've been struggling with this one, unable to find a good solution out there.

For some reason, on one of my forms, al the inputs act weird - whenever i make a change in the text in them, it throws the cursor to the end of the text/input.

This is really annoying and I'm not sure what I'm doing wrong.

Did anyone come across this issue before?

ok, i figured it out after painfully duplicating my app and removing one component/query/script at a time to try and isolate the issue.

After clearing the entire canvas and all the query/scripts custom css etc i tried to look for something in the app theme and eventually reseting the app to the default app theme solved the issue :man_shrugging:

Anyways if inputs are funky try reseting the app's theme. Not sure why, but i guess it might work.

Same issue here, and it's not connected to themes.

In some cases it could be fixed by upgrading deprecated input fields, but I haven't found a complete solution yet.