Input query in module used by module doesn't get triggered

Hi all, I have a small problem with an input query in a module.

This is the structure right now:

APP uses MODULE1 that uses MODULE2

The MODULE2 has an input query that is passed by MODULE1
On succeed of this input query the MODULE2 triggers an internal JS Query

But this does not happen.

How the query is setupped in MODULE1

This is where I pass the query to MODULE2

The Input Query inside MODULE2

The timeline inside the app

I tried logging what happens and this is the output:

  1. Called query in MODULE1 (a log inside the query)
  2. Query succeed in the MODULE1 (a log on the succeed trigger)

The input query does not get called.

Thanks for your time, any help would be much appreciated.

Have a nice day,

Hey @Matteo_Graizzaro!

Unfortunately, this is a bug on our end :pensive:

Currently, queries passed into modules don't trigger other module queries on success. You might try using the workaround described here to trigger the query instead, i.e. have an intermediate Query JSON with SQL query that listens for {{ }} and then triggers FillDataForTable.

Can you let me know if that works for now? We'll be sure to report back here when the underlying bug has been fixed!

Thanks for the answer @Kabirdas
I tried you solution, and with some tinkering I made it work.

This is the SQL query that listens to the input query provided by who uses the module:

In its Success event handler I trigger the JS query that was my objective and it will use the result to do its things.

My problem was being focused so much on using inputs instead of the result of queries. Once I understood that I could use the valure returned in the Input Query, in the SQL one, everything became much simpler.

Thanks for your help, I hope you will fix the bug ^^