Import CVS to Firestore - timestamp issue

I am using retool to import data to my Firestore (with csv). One of my data is a timestamp but when i upload it to Firestore, it's getting store as a String and not a timestamp.
I try to use the moment() object but it doesn't create it as a timestamp

In my Firestore :

Do you know if i m doing something wrong for that import ?

Hi @Ordell!

From those screenshots it looks as though you have things set up correctly :thinking: would you mind opening your browser console then navigating to the network tab, running the query, and checking its payload for the valueParams being sent?

I'm also curious to know what version of Retool you're running.

Have you tried the same with a different query as well to check if you see the same behavior elsewhere?

Hi @Kabirdas,
Thanks for your help. So I ran the querry and check in the browser console and I got this :

Version of Retool :

I tried with a new request and only create this data :

But i got the same result :

And in my Firestore :

Hey @Ordell,

Thanks for sharing those screenshots! It looks like you're wrapping your data as a string using double-quotes. Are you able to try removing them and see if it saves it into your DB as a date?

Hi @Kenny !
Thanks, I removed double-quote and indeed my data is saved as a date :slight_smile: