Image not shown for other users

I have a module that has a navigation bar, lists the name of the current user, and an image. The image is uploaded to storage (it is a png, I have also tried a jpeg. The module is used in several apps. The image appears when the user is Admin who created the module. It does not appear when the user has there permissions set to "Use". The nav bar functions and the current name of the user appears.

I changed the user so they have admin privleges( tried edit and tried own). An outline of the image appears but nothing there. The file input is blank. I have tried uploading the file and I get "Unable to add new file 401".

Is there some permission for images somewhere I am missing?

I am also seeing this issue

@clay123 this isn't a solution per-se more of a workaround, but what about current_user.profilePhotoUrl?

For me, i think it's the same for clay123, the image that's not showing is not a user-specific one: it's just a jpeg that I uploaded directly into the app builder from my documents.

1 Like

@Joshua_Hampson @clay123 under Preferences > Permissions > (your group) > Resources there is Retool Storage, have you tried changing those permissions around?

2 Likes

Yes thank you that fixed it! I didn't think to tick that. many thanks