I added a chart to my retool app for experimentation and now the app crashes and won't load whenever I open it

I had a query pulling in some data from dynamodb. I then added a chart component to my retool app to display this data. I pointed the chart at the Items in the data returned by my dynamo query.

At this point my app crashed. I keep trying to reopen it (on multiple machines) but the webpage displaying the app just times out/crashes.

My guess is the chart load is super expensive causing the app to crash. This is just based on the fact that as soon as I added the chart the app started crashing.

I can't do anything with my app now.. can't edit or view it at all as the page just never loads and crashes when trying to edit/view it.

I have no idea what to do now as I can't even view the app to debug or see what I did. It's extremely frustrating but I figure there must be an easy solution? It can't be this easy to just render an app unviewable or uneditable.

Thanks in advance!

1 Like

Hello! Thanks for writing in. Hoping to figure this out for you!

So, the first thing you could do is add ?_historyOffset=10 to the end of your URL which will allow you to "travel back in time" 10 steps. You can increase the number to go further back in time if you still don't see any app data. The idea here is to go back to the most recent working version before the chart so you don't have to redo as much work (i.e. going back 10000 steps would likely work, but it could be many, many changes behind).

***WARNING!*** If you make any changes to the canvas when traveling back in time, that past version will become your present version and it messes with the history, so be careful not to touch anything! Once you find a version that isn't crashing and you'd like to make that your present version, then you can make an edit to the canvas (move a component, add a component, etc) to persist that view.

The other thing you could do is download the JSON and make whatever change you wanted (deleting the chart component for example) and then import the new JSON and go from there. If either of these suggestions gives you any trouble, please let us know! And, if you can share any console errors in the future that would also be great! :grinning_face_with_smiling_eyes:


Sorry to resurrect an old thread, but this is still the top google result for this issue.

The history step-back will fix this issue (accessed via the three dots in the top right corner) but, if you are like my team and didn't realize this was an issue until many other things had been worked on, you might be looking for alternative methods.

Here's how we were able to delete those charts and why we think it happens.

How we fixed
I don't guarantee this by any means, but it worked for me on both our apps that had this 'posion' pie chart.

  1. Change the query the graph is pulling data from to be a tiny table. For example ours was a table we have that is about 4 rows with 4 columns.
  • When the query was intentionally, broken it appeared to crash still.

  • This might be optional but I believe it probably lessens the load to convert the graph.

  1. Change graph type to bar graph.
  • This might still lag out but when I loaded the page later after leaving it overnight it was a bar graph.

  • The second time it took maybe 5 minutes of me just waiting while it loaded.

  1. Delete graph.
  • I also hid the graph and deleted from the left side panel but I don't think those mattered because when you select the object to delete it just loads/shows anyways

For some reason the chart is trying to load 5000+colors to use. I don't know why THAT occurs but I do know that the crash seems to be directly related.

1 Like

Thank you so much for sharing these details, @AndrewRussell!

I've shared this with our team internally, as we'd like to work on a fix for this behavior. I'll post back here if I get any updates from our team internally

1 Like