Hyperlinks not working

Just noticed that my existing hyperlinks in the mobile app, in the HTML components are no longer working. They show as a clickable hyperlink but clicking performs no action, whereas the basic action of opening a web browser no longer works. Nothing in my code has changed (that I am aware of) and all links no longer work.

Any suggestions would be appreciated.
Thanks!

<div class="myClass">
  <a href="https://www.google.com" target="_blank" rel="noopener noreferrer">click me </a>
</div>

I got this to open google in a new tab using a HTML Component. not sure how else to help without seeing what your HTML component or the hyperlink tag looks like that you're using

<a style="font-weight:bold; font-size:1.5em;"href="http://65.110.38.101">Broadband Services Tools</a>

I have several links throughout the app that won't open a browser on both the online "web" view and in the app on the phone itself. They used to work and just noticed today that they no longer launch a web browser.

try refreshing the page, clearing cache and stuff. I just tried your tag as is and w the added target="_blank" rel="noopenner noreferrer" props as well as desktop and mobile, they all worked. I would suggest adding those, they prevent a type of attack.

Tried in a new private window and on a different device... same issue.
Wondering if there's like some sort of internal setting in Retool preventing links from opening

I created a brand new mobile app with a HTML component and placed this code in. Same results. Clicking the link does not launch a web browser or open a new tab (when viewing app in the browser). Not sure what changed...

oh I see now, I was just using the mobile layout of a normal app. My bad, I just tried in a new mobile app and I got the same results as you.

This was working recently and I believe either I have messed up some system setting somewhere or, if you are also experiencing the same issue, looks like a platform bug.

ya you might want to edit the title and add the 'bug' tag, or @Tess can you add the bug tag for him?

bump. I'm not able to edit the title of the original topic and still having this issue with all links in all mobile apps.

I just recently gained the rank to edit that for ya, hopefully it gets some more attention here for you.... cause I'm oldskool.... bump :rofl:

1 Like