How to change uid in CodeExecutor pod in Openshift

hi, I launched retool in Openshift, but CodeExecutor pod has this error: Code executor container is specified to run in unprivileged mode (CONTAINER_UNPRIVILEGED_MODE=true) but the user running container is not the expected user, retool_user (uid 1001) in retool_user_group (gid 1001)
How to solve it?

I am facing the same issue when deploying retool on GKE Autopilot cluster with unprivileged mode. How to solve this? Please help!

Thanks for reaching out! You'll need to set up the container to run the startup command as retool_user (uid 1001) in retool_user_group (gid 1001)

For Open Shift, I would try setting the securityContext at the pod level, with runAsUser, runAsGroup settings as such:
‚Äč
securityContext: privileged: false runAsUser: 1001 runAsGroup: 1001 fsGroup: 1001

Similarly for GKE Autopilot, I believe there is also a securityContext.runAsUser setting

For other folks that may be running into this error, in the case of ECS / Fargate, see "user"

Let me know if you run into any issues!

I set config below, but still get error above. I used helm chart for k8s. What is the problem?

securityContext:
    privileged: false
    runAsUser: MY_UID
    fsGroup: MY_UID

Thanks, @Epic555 :disappointed:

What is the version of the helm chart you're using?

6.2.5