Hide/remove horizontal scroll in table

I've created a scrollable table. The end user should be able to scroll vertically, however also a horizontal scroll appeared. There is no column or data to scroll to horizontal as everything is already in view.

How can I remove the horizontal scroll? I would like to remove it, as it doesn't have any function.

Maybe you can't remove it, it was calculate automatically. Maybe you can narrow the width of column to make it disappear.

1 Like

Thanks for the suggestion. I made the columns super small in width. I did this before, and in some cases it made the horizontal scroll disappear. However, since about 2-3 weeks it is permanently there, no matter how small the columns are...

Yes, it's some problem about the column width, I feel the same situation something. There are many request about this topic. Hope retool fix this quickly.
It seem retool store your column setting, maybe in broswer's localstorage or database.

My case is we can't narrow the last column's width, when you drag it, it will lost, and the adustment will apply to the second last one. It's so anoy. Seem will be fixed in near coming update.

especially you use a large monitor to edit the app, then next time you use it in minor monitor, this problem is more apparent.

Let's hope they fix it soon :pray:

Same problem, this is in all table rows sizes, no horizontally scrolling !!!!