Gmail Authorization Issue (gmail api)

Hi, this is my first post, and I'm VERY new to retool so forgive me if I am not providing all relevant info or doing this wrong....

We have a legacy tool that allows us to process some information, and part of the process of the tool is to verify the required information has been provided, and if not, omits the data from our processing.

The omitted data is then placed in a .csv, and appended to an email, sent via gmail.
We recently updated our google workspace 2FA and since then our email will not send. We receive and "invalid authentication credentials" error (screenshot included).

I have created a new client id and client secret but that didn't work. I also tried creating an entirely new gmail resource which also hasn't worked.

I would greatly appreciate any tips or help determining the next step for this, if anyone has any thoughts. Please also let me know if you need additional info (much of this is still very new to me so I may not understand some of the more technological info).

This is my first post so I can't upload screenshots, but I've collected them all in the google doc below.

Omit Email Schreenshots

Thank you very much.

Hey @Matthew_Morrison! A couple of questions:

  1. Are you able to successfully authenticate to the resource on the resource setup page with the Connect with Oauth -> button? If not, can you share the error?

Screenshot 2023-11-27 at 8.27.17 AM

  1. If you can authenticate successfully, if you Preview the send_omits query and then click on the API Request tab, do you see the appropriate Bearer token being sent with the request?

Hello! Thank you very much for your response. I am not able to authenticate the resource. I receive "Error 400: redirect_uri_mismatch" but to my knowledge we've never had an authorized redirect URI for this.

I don't believe you can successfully set up Oauth2 authentication without the proper Authorized redirect URI in the Google app. If you add in the redirect URI, are you able to authenticate?

1 Like

Thank you very much!!! I was able to get this to work. Just needed to add the redirect URI. I really appreciate you help.

1 Like

Awesome! Glad to hear that it's working!