Get Query URL Parameters trailing tab character

Hi all!

I have been trying to work with the Data API of Claris Filemaker.

There's an issue with this GET query and I'd like to try sending the request without the trailing space and Tab character, as I suspect this might be the issue.

I've come to this conclusion, since the return message usually has the format
"message" : "Unknown parameter(s): fieldData" and in my screenshot it seems it is returning an empty character.
Unfortunately I can't use a different service like postman, since this is an IP restricted resource.

Is there a possibility to do this or another workaround?

Thanks in advance!

  • Screenshots:

Welcome to the forums! Is the URL value coming from a component? A quick hack might be to add .replace(/[ \t]+$/g, '') to the reference, though you may need to play with the regex depending on what else should be in the query.

Thanks! The request is being made in the Retool query builder, so it's not coming from any component.


So this must be a retool default behavior, right?

Not that I’ve experienced; are there other parameters that you have set for the url that are blank or something like that?

No, it's completely empty...
I've tried making a fresh new query, same results.

Playing around, I just re-created the resource once again from scratch and alas now the trailing character is gone! Mind you, I did not change anything in the resource config.

So while this may be the fix for the problem, maybe @retool still want to take a look at this behavior...

1 Like

Hi @BIGstudio, welcome to the forum! :wave:

Thank you for sharing details on this. We were unable to reproduce it but I'm glad re-creating the resource worked.

We'll keep an eye open for other reports. :eye:

Hi Paulo,

Thanks! Just following up with some more details, for anyone with similar problems, since I have been playing around with it some more:

The trailing tab character (\t=) issue has come up a couple more times and it seems to occur when the resource is configured with a trailing slash / in the Base URL.

Re-Creating the Resource without a backslash at the end seems to be the remedy.

Also it seems that most APIs don't care about the Tab Character.

1 Like