File upload failing for sending email

I've tried the FileDropzone, FileInput and FileButton and all 3 fail to upload.

I've tried passing through the .value and .value['0']

I keep hitting this error.

SendEmail: {"status":400,"message":"Use File Picker to upload a file and ensure file is uploaded before query is fired.","error":true,"queryExecutionMetadata":{"estimatedResponseSizeBytes":110,"resourceTimeTakenMs":0,"isPreview":false,"resourceType":"smtp","...

Can you add some screen shots and the names of the components you are using (i.e. fileInput1)?


Have you tried:
The i can be used when you have more than one value and want to attach more than one file...
Also, maybe you have to check that the file is being attached before sending the email as the error states...

@rcanpolat Please could you share a screenshot of the query that you are using for this?

please hide sensitive data


I see a value if I use i or 0

The following 3 show me the same identical string.

* {{fileInput1.value[0]}} = string
* {{fileInput1.value[i]}} = string
* {{fileInput1.value['0']}} = string

And it doesn't show any value like I posted in the screenshot?

It does, i see a string like yours, but when I run the emailer it shows:

"Use File Picker to upload a file & ensure file is uploaded before query is fired"

That's odd.... reach out to support - they may know something I don't.... or mark this as under support

Hello @rcanpolat,

Please could you use this format?

Same issue. That didn't work.

I've just found the issue. On the right side of the "Attachments" field for the emailer there is an Fx button. Click it to "click to use a multiselect". The field then provides dropdowns where i can pick fileDropzone1 and it successfully emailed the attachment.