Eventbrite rest api calls

Eventbrite's API calls are structured as follows:

Trying to figure out how to map this into the sources in Retool. I have tried with bearer token and just the token provided. Getting 403s.
I need to provide the api the organization and bearer token somehow but now sure how to set those up in the Retool config for a resource.


@dbrum Welcome to the forum!
Have you checked out:

Do you have your calls working in something like Postman or Insomnia? If so, use the below as a guide and just copy the same settings.

  • Login to Retool
  • Click Resources
  • Click Create New
  • Click Resource
  • Click Rest API

  • Complete the form

Yup calls work fine in Postman and http on browser.
On here I get this:
"status_code": 403,
"error_description": "The feature that you requested is not available to you.",

Are you an app partner?

I just signed up for EventBrite but was able to successfully complete a call. I used their API explorer to make a get request to retrieve my organization. All it is doing is making a GET request to https://www.eventbriteapi.com/v3/users/me/organizations/.

I took that id returned in the Body and input it in the url in screenshot below.

No events because I just signed up and haven't added anything.

1 Like

Thanks. I think my issue is the bearer token setup in the config for this query.
Can you show exactly where and how you set it up? I see in your screenshot it's a param named 'Authorization' and you specified "Bearer xxx" as the value? If so, tried this and having the same issue.

Eventbrite for Developers - Eventbrite Platform is where I got my token. Other than what you see in the screenshot, there are no additional settings except that I whited-out a portion of my API key.

Double check the URL? I was running into your issue, but my endpoint was off.

Here is my setup - blanked out the param and token. Exact same setup in Postman works fine.

Same error:

"status_code": 403,
"error_description": "The feature that you requested is not available to you.",

DOH! You were right... i was missing the /events path after my org ID in the call! lol problem solved.

The Ux makes it a little hard to see the issue, but your comment made me double check everything.


Sweet, glad we resolved it! I think that's exactly what I was doing wrong when I first started playing with it too.

Feel free to mark the answer so other's can quickly find it in the future!

One more follow-up on this i can't find an answer to in the docs.
The query now runs and returns data. I placed a table into the app builder and want to link it to the query, but I see this error:
"The selected data source is empty or could not be converted to an array."

What's the next step to making the data in this query available to use in a ui component? I think I'm missing a step clearly.

Can you take a picture of the query results and your main table settings?