Error adding data to the Retool Database Beta

I've created a table in the Retool Database by loading a CSV file. This worked as you can see:

This is (part of) the csv file I used:


I then created a filebutton in my app to load more data:

Using this button, I tried to load more data in the same csv format as above (minus the first line headings).

This is the query that the button runs:

And this is the error:


What am I doing wrong please?

Hey @Argy! Happy to help with this :slight_smile:

Looking at your query3, it looks like you'll need to put data into the "Array of records to insert" field.

Let me know if you have any questions about this!

Hi Victoria. Thanks for that. It got me further, but I get a different error:

BTW, this is a subset of the data I am trying to load:


Actually, Victoria, I fixed it myself. I hadn't realized that the first line of the file to upload had to contain the column headings to map the data to. While this will be inconvenient for the App's workflow, I think we can work around it. Many thanks for your help. Argy.

1 Like

Amazing! Glad you found the solution here. Let me know if you need any further help getting this set up :slight_smile: