Documentation on Auth0 authentication missing

Hi, I'm trying to setup our login with Auth0 so Retool can call our APIs with the correct credentials.

I've tried Custom Authentication, OAuth2 and Auth0 and neither of them is working as intended.

Since we're using Auth0, I expect that option to be the simplest, but I can't see any documentation on how it's supposed to work - nor I can see any prompt to login or anything like that.

Help would be very appreciated!

Hey @mikearagao! We do support Auth0, but I do know we generally point users to OAuth2.0. Would you mind sharing a screenshot of your current config? Are you getting any specific error messages when you run a query against the resource?

Hi @victoria thanks for replying.

I guess there's 2 separate problems, so I'll try to separate them.

1. The Auth0 option doesn't seem to trigger any prompt to authenticate
As much as I would prefer using this, it simply doesn't seem to work. There's no prompt whatsoever - nothing.

I consider myselft quite knowledgeable in this type of architectures and patterns so I don't understand what I could be doing wrong, and how don't you have many more people asking for help on this? Is it because no one uses these features?

Either way, I'd prefer focusing on point 2, as I can see it working although I believe there's a bug with the auth verification endpoint feature.

2. When using the OAuth2.0 option the prompt doesn't show when it should
I have the authentication working with this option however there seems to be a bug with the prompt on the app.

I will share some screenshots but to summarise, I have implemented the auth verification endpoint and when I run the test in the resource page it tells me it will prompt the user to autenticate, however, when I visit the app it doesn't prompt and I need to manually click on the option to show the dialog.

That dialog says Authenticated in green which seems quite buggy. My theory is that maybe there's a bug that is checking if any other user is already authenticated and then the current user doesn't see the prompt - something like that.

I would really appreciate if you can have a look.

Screenshot 2023-05-18 at 20.51.12

Please let me know if you have any further questions, I'm quite keen on convincing the team Retool is a good option, but such basic functionality working so randomly is not helpful.


Hey Miguel! If you’re still running into issues here, I’d be happy to discuss more over a call :slight_smile: Auth is often pretty specific to the org, so it’s a bit tricky to dive deeper into your setup.

As a quick note, is the OAuth 2.0 not prompting in both edit and preview modes? We don’t prompt in edit mode!

hey @victoria i'm trying auth0 but i couldn't find the configuration you are looking at, is it possible to hop on a call?

Hey Ismail! If you create a Rest API resource and then click the "Authorization" dropdown, do you see the Auth0 option?

A post was split to a new topic: Auth0 authentication option

A post was merged into an existing topic: Auth0 authentication option