Decimal separators showing as coma and as periods

Hello community:

The number inputs in my app show the decimal separator as comas. I see other posts that state that they usually appear as periods and they want comas. In my case I just want the normal!! Periods as decimal separators. The funny thing is that when I show values in text components, the decimals are displayed with periods... strange... Is there any way to change this?

Have you set the column to be of Number format or are all of these fields textInput fields and not in a table?

All these are textInput fields.

Hard to say what is happening as the inspect panel is not shown for the field where there is a comma...
You should be using number input type field instead of text for all fields even when summarizing...

It is strange, isn't it? I am using all number inputs. Or you mean the text components where I show totals? This is because I concatenate it with the string "Cost: ". That works fine, and that's the only use. The number inputs showing comas is what I find strange...

Hi @ggallese the formatting is automatically based on locale :confused: We have a feature request for more settings options, so I'll let you know if we ship any updates!

1 Like

Ok I see, thanks Tess!

We shipped a localization beta (docs here), but it's currently only available for Enterprise