Database Date - Time Column Type, having an issue with Now()


I have a Retool DB Table, with a column of type date-time. I have set the column to;
UTC + 2
Default value: Now()

I use a workflow to bulk inserts some data into the table. The Date - time column should log the time of the insert, therefor set to Now().

When I run the first flow, the insert was performed correctly and the date/time is correct. However Retool automatically changed the column settings of the column. It changed the Default Value of the column from Now() to the date/time of the insert.

When I perform another insert, 12 minutes later, the printed time is the time of the previous insert and not Now()

Schermafbeelding 2024-05-03 160001

Shouldn't the default be CURRENT_TIMESTAMP()?

1 Like

Thanks. Now() was prewritten by Retool.
Unfortunately it didn't seem possible to specify CURRENT_TIMESTAMP() into that field.

I solved it for my case by pushing the date into the column straight from the workflow instead of setting a default value.

1 Like

Good to know - thanks for the follow up.