Custom Auth Token

I have trouble setting up the authentication correctly for Citrix Sharefile. I set up a custom auth workflow: the first step is Oauth2 and the second step is Define a variable.

When I run the Test auth workflow, I can see the accessToken returns correctly. However, when I run the query, I receive "Invalid Authetication" message from Sharefile. The query works if I copy the access token string from the Test auth workflow and replace the TOKEN in the auth header with the actual token string. I wonder if there is anything I missed in the setup. Thanks.


Hey atai! Glad we were able to get this working properly for you in a support thread. For this particular resource, checking the Forward all cookies checkbox allowed the in app requests to be successful.


I found out the Forward all cookies checkbox does not actually solve the problem.
It seems like Retool is not sending out the Auth Token correctly. It turns $$ inside the toke into $ either when saving or sending out the token.

See my screenshot below. The first image shows the API request and the second image shows the "Test auth workflow" result.


Is there a way to fix this?


Hey atai! Thanks for reaching out again. I was able to reproduce this issue and have submitted a bug report. I'll update you here when I have any new information!

Hey atai! Looks like a fix for this has been merged. It should be out in a cloud deployment next week. Have a great day!

Thanks. It is working now.