Collection Name Cannot be Empty

I've been stuck on this for a few days now. I've just started with ReTool and MongoDB so clearly something I'm doing wrong.
I created a free shared Atlas MongoDB. I loaded it up with the sample data & collections they provide.
I got ReTool started and created a project, set up the MongoDB in Resources using the "Use a database connection string" tested the connection and got green connections.
I dragged a table into the project and created a query connected to the MongoDB resource and thats where I've ended. While the resources show green, connection successful, the collections in the query are empty and show "Collection names cannot be empty".
Ive tried deleting & re-adding both the database & collection in MDB, tried deleting and re-adding the resource in ReTool, tried a new project and new query but cannot seem to get it to work.
What am I missing to make this work?

Hi @blastingbytes, this error usually appears when you don't specify a Collection to query from.

Example of error:

You'll need to select a Collection from the dropdown in your query editor (bottom panel in an app) to get this to work. Here's a screenshot of where you can find this:

Hope this helps! If you're still running into any blockers with this, it would be helpful to share a screenshot of how you're setting this up and the error you're receiving. :slightly_smiling_face:

Hi Kenny,

I looked at that and so far it shows No Data

The MongoDB has sample data in it, but for whatever reason its not seeing the data and there is very little in the way of diagnosing or seeing more helpful errors as to why it can read this data even though the connection was successful on the resources tab:

Here is the sample data in the MDB Collections:

Thanks for sharing your setup!

Are you able to paste in your connection string manually? Your connection string that MongoDB copies to your clipboard is going to look something like mongodb+srv://gagejustins:<password>

You can read more about this in one of our tutorials: Building a listing approval tool in MongoDB

Ah yes, the specific point that I seemed to have missed was it is imperative to link directly to the collection as described here:

I really wish this was made clearer in the documentation but glad you pointed me here!

Woohoo! Glad to hear that worked for you! :+1:

In case future users come across this again, here are our docs for Connecting to MongoDB Atlas Clusters.