Cannot query Firestore documents

Hi there,
I am using Retool with Firestore. But I am confusing in here. I have a document called chapters, the structure of chapters is:

I have a list of ids, so I want to query the documents that existed in A. But it's not working.
But I changed firestore.FieldPath.documentId() -> __ name __ it's worked very well.

I often use firestore.FieldPath.documentId() in my Cloud Functions and it's still worked.

Hi @phamtiennam23 :wave: thanks for reaching out with this!

As you observed, when referencing field names in the query builder form, the Firestore service methods/properties (i.e. the documentId() method) are not available within the context of the form fields; it'll be required that you either reference the field name as a static string, or from within a custom JS snippet (i.e. accessing an app value with the curly bracket syntax {{}}).

I hope that this helps clear things up a bit, but please feel free to let us know if you have any other questions too!

Hi @luke-phillippi
So, how I can query the documents that have ids existed in the array, expect using __ name __ in where condition