Cannot login or reset password on an on premise install

Installing on k8s using retool-helm and default postgres install. Values.yaml setup as per online doco
I have my license key inserted

I can login to and see my account all ok.

I get the login screen for local retool but getting "incorrect email or password" whenever I try to login. Have tried all variations of passwords, past and present. When I click on "Forgot Password?" I get the reset password screen and enter my email address and click "send reset link".
At this point I get a bizzare email telling me firstly that someone tried to reset my password but not to worry as no changes made to my account and in fact I don't have an account with my email?

Any help appreciated. I see there have been others with similar issues in the past but I couldn't find a resolution trying out all suggestions I could find.

Hey @stuarth!

Once you set up your self-hosted deployment did you go through the step of creating a new org at the login page? You'll be creating a new database with fresh user tables etc. and with that, a new user to log in with.

The account at is specifically a billing account that's associated with your deployment via the associated license key. It can be switched out by changing the license key without necessarily impacting the instance otherwise.

Answer from Laurente

I was being redirected to /auth/login all the time by my browser (account with shared bookmarks etc.). Login wouldn't work until I had completed the signup step, which I had forgotten about.

So went direct to http://localhost:3000/auth/signup in order to setup org on first login. And all is now well.


1 Like