Cannot establish an encrypted connection to SQL Server

I am getting the 'Unable to connect. Error: Failed to connect to - socket hang up' error when connecting to SQL Server with encryption (and trusting the server certificate).

The SQL Server has TLS 1.2 enabled and I confirmed that when I connect to it using other tools, a TLS 1.2 connection is established.

I can see that the handshake fails on the server (in xEvents):
SNISecurity Handshake failed. PeerAddr: 5

This is SQL Server 2016 SP3. I have no problems with any other tools or applications connecting to the server with encryption.

Hey @serggusak!

Not entirely sure but will certainly investigate! Out of curiosity, does the connection work without using TLS?

Hi @Kabirdas, yes it works without TLS. I also had no problems with connecting Retool to SQL Server 2019.

That server was SQL Server 2012 that did not support TLS 1.2. I installed SP3, which adds TLS 1.2. The error message changed to what it is now. Then I upgraded to SQL Server 2016, but still get the same error. I have no problems with connecting to that server with other tools and applications using TLS 1.2.

Hey @serggusak,

Sorry about the late reply here. It looks as though this may be an issue on our end and our engineers will take a look into it. For some context, are you using an MSSQL resource for this connection or a MySQL resource?

Thank you, @Kabirdas. MSSQL (Microsoft SQL Server 2016)