Bug with app showing default "create new" loading page

Honestly unsure if feature requests is the correct place to put this but wanted to see

a.) If others were experiencing a similar issue, or if
b.) There's something I can do to fix this?

Essentially as I'm working through a multi-app flow I am regularly being greeted by the default "Create App" screen. Sometimes it is only flashing before my actual app loads, other times it takes a full refresh to fix, and still other times it won't go away at all.

I have tried to clear my cache etc., but it seems to be persisting. Wondering if this is something on Retool's side? My apps have been fine all day, but something has seemingly happened recently.

I am starting to get just ever so slightly concerned that pieces of my app are somehow being lost, as my version control is also missing, even though my app name etc is all correct, and my goto app triggers are taking me to the 'right place'.

Hello @Chris_Doty!

Apologies for the buggy behavior, I would love to try to trouble shoot this with you.

Definitely want to see if any other community members have a similar issue and if they have any preferred methods for moving between apps and addressing this.

What is the method you are using for going between apps? Are you using a button with the Action set to 'go to app'?

I don't think you need to worry about pieces of you app being lost, I just tried switching between three apps really quickly and if there were any unsaved changes there will be an alert letting the user know of unsaved changed and offering a yes/no option for not leaving the page if there is a risk of unsaved changes.

Let me know what else I can do to help!