Bug: editable text validation incorrect for default value


At the moment the Editable Text component contains a bug which makes it difficult to use for my use case. I am trying to create a "read and edit" view for a single database record. When the user views the page, the information on the page appears static, but the user can edit fields via the editable text field and then click a "save changes" button to save only the fields that they changed back to the database.

However, if a user doesn't change the field, the validation raises an error: "field is required", despite the fact that the field is populated.

It appears that the reason this is happening is because the validation is done on the inputValue property. However, when the page first loads and the fields are populated with their default value, the value property is set but the inputValue remains empty. It is only updated it the user changes the field. In my opinion this is a bug. The inputValue should be populated with the default value along with the value property.

Hey @jrobin1917 thanks for bringing this to our attention. I'll escalate it internally and we will circle back with next steps!

1 Like

Hi @jrobin1917, you're right! This is a bug we're aware of and is currently working on. We've notified the engineering team, logged it and we'll ping you again once we've fixed it :slightly_smiling_face:. A workaround to that worked for other users at this moment is to replace your Editable Text component to a Text Input component. Hope this helps!

1 Like