Automatic Custom Auth not Working for gRPC


We are running the latest version of self hosted Retool and have grpc resources with custom auth and have the "Run this custom auth workflow without prompting the user" checkbox checked yet it does not seem to run properly. We must go into each resource and click "test auth workflow" and then the resource works. Seems like there is something broken in the auto running of the workflow.

Any help appreciated! Thanks!

Hi Rob, I'll help look into what's going on and report back when I find out. Hang tight -- thanks for your patience.

Thanks for your patience here. So, this would depend on your auth trigger in your custom setting auth. Do you mind writing in to our support team ( so they can dig in a bit more for you?