Auto height not working for "expand content to fit" - Double scroll still appearing - large table


I have tried for a couple of hours now and can't find a way to deal with the double scroll that is forming in my app:

I created a container and a table inside it. In both the main frame and the container, I have selected the "expand content to fit". In the table and the container, both, the height is set to auto and uneditable because of the "expand content to fit" setting (which is OK). I would assume that the height is adjusted to the max height of the components inside. I would assume that the table would not have a scroll if it is set to height auto.

I tried also without the setting "expand content to fit" but works the same way. I can't find a way to solve this. I even tried with custom CSS but no success.

Anyone with the same issue?

Just found it lol... gave it a last try....

For some reason there is a max-height property set to 100vh in the table component. Overwrote this with

._iLw0I._iLnJ\+ {
  max-height: initial!important

Hi @ggallese! Thanks for flagging this -- when components are inside a full bleed container we typically try to override the height type to be fixed height on Retool's end to avoid scrollbar issues like this. For some reason this doesn't appear to be working as expected for Table -- I'm looking into a fix for this!

In the meantime to avoid needing custom CSS to make it work, you can un-check "Expand contents to fit", change the Table height to be fixed height, and re-enable Expand contents to fit -- this should allow it to render without double scrollbars!

1 Like

Update: merged a fix for this that will be available in the 3.36 cloud release next Wednesday!

1 Like

That's great! thanks! Something similar happened to me with the new list view, you may check that as well. My fix was similar:

._luK0B._cN86F {
  max-height: none;

@ggallese This should be fixed as well! The fix is live on cloud so you should be able to remove the CSS override -- let me know if you encounter any issues

1 Like

Thanks! It works.

1 Like