Auth Verification Endpoint working on 1 resource but not another


I am trying to set up two resources for my retool apps, one a GraphQL endpoint and one a Rest API.

I have enabled an auth verification endpoint so users will be automatically prompted to auth. The issue i'm running into, is that the auth verification endpoint works correctly for the GraphQL resource, but keeps saying "Not Authenticated" for the rest API resource even when the resource actually is authenticated.

I've tried numerous things when troubleshooting this. I even tried copying all the details from the GraphQL resource over to the Rest resource to try it, and still the Rest one says not authenticated. I also made sure to keep saving the resource config between changes, because I know that was an issue for me before.

The auth verification endpoint is configured exactly the same between the two resources.

And if I try to run the exact query I'm using for auth verification, using the rest resource, from within a retool app, it works perfectly and gives me a 200 response code.

I'm really confused about why this isn't working. Does anyone have any tips for what I can do to help troubleshoot this?

Here's the screenshots of the config between the two resources, for the custom verification endpoint.

Thanks for any help!

Hey @tombilske,

I've had a similar problem when it comes to using the "automatically prompt users to auth" when using two resources that require authentication. Your bug sounds awfully like the bug that I was experiencing. The way that I got around this was by toggling this off for both resources.

This will prompt the user to click both resources on page load (will be an additional two clicks), but I think this should solve your problem.


Hey all :wave: Thanks for your answer JoeyKarczewski! You were spot on with your workaround there. This is a known issue on our end. When an app has more than one resource with custom auth flows and each has the setting
**Run this custom auth workflow without prompting the user, **the first auth flow is able to complete but the second flow is not. My suggestion to sidestep this issue is the same as Joey's!

1 Like

Hey @tombilske, I just wanted to let you know that a fix for this issue has been shipped to Retool cloud!